Recently Found Double Spending Vulnerability Is Not Tether’s Own, SlowMist Confirms

SlowMist has confirmed that Tether’s double-spending vulnerability was not caused by its own blockchain, but rather by some crypto exchanges’s poor practices

The post Recently Found Double Spending Vulnerability Is Not Tether’s Own, SlowMist Confirms appeared first on bitcoinmining.shop.